problems with reading Excel file generated by reporting services

Apr 5, 2013 at 2:14 AM
Hi there,

First, I'd like to say thanks for a great plugin. I have an issue however - the plugin doesn't like the Excel files that are generated by reporting services. If I open the file in Excel and re-save it, then it works fine.

The problem has already been reported here:

https://exceldatareader.codeplex.com/discussions/280390

... however the person reporting it no longer required a fix, and the last post by Ian was that he needs a sample file to investigate this.

I've uploaded a sample excel file here:

http://www.appointmentsms.com/test.xls

It opens up fine in Excel, however if you read it with ExcelDataReader you will see that the last character in each cell is chopped off. Then, if you open it in excel and re-save it, it works fine.

If you could take a look at this and fix or advise on a work around I would be very grateful :)

Cheers,
Michael
Developer
Apr 5, 2013 at 9:32 AM
Have you tried the latest source from the repo? Changeset 82970 has a SSRS related fix in it.
Apr 9, 2013 at 6:19 AM
Ahh yep, that fixed it :) I was using the binary's from the home page.

Thanks Ian