Try to compile v2.1 (82323) or v2.01 (27264) failed

Oct 29, 2013 at 5:49 PM
I tried to modify the source of version 2.1 and when i compile it didn't work :
It is mentioned in the home page that framework 2.0 should be used.

I've got visual studio 10 on seven with framework 3.5 and 4.0

I tried to modify Excel\Build.Debug.CF.bat to access the correct csc compiler and the required assembly needed :

so i set:
SET CSC=C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\csc.exe /nologo
and i set also:
set NETCF_PATH=C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

i had also to create the missing sub-directory and file:
Binaries\netcf-20\ICSharpCode.SharpZipLib.dll

But the compilation failed with those errors:
ExcelDataReader.cs(152,45): error CS0117: 'Excel.Core.BinaryFormat.XlsWorksheet'
    ne contient pas de définition pour 'Data'
ExcelDataReader.cs(306,10): error CS0117: 'Excel.Core.BinaryFormat.XlsWorksheet'
    ne contient pas de définition pour 'Data'
It seems "Data" member doesn't exist in Excel.Core.BinaryFormat.XlsWorksheet' class

Can you confirm me that I must use Framework 2.0 to compile v2.1 version (82323) ?
Can you confirm me that I must use Framework 2.0 to compile v2.0.1 version (27264) ?

Thanks in advance
Best regards
P. Gineste
Oct 31, 2013 at 11:03 AM
You don't need 2.0 to compile.

I quite happily use 4.0
Oct 31, 2013 at 12:13 PM
Thank you very much.
I succeeded to compile


___________________________

Pascal Gineste
GFI Informatique
04 76 61 30 29



De : Ian1971 <[email removed]>
Envoyé : jeudi 31 octobre 2013 11:03
À : Gineste Pascal
Objet : Re: Try to compile v2.1 (82323) or v2.01 (27264) failed [ExcelDataReader:464093]

From: Ian1971

You don't need 2.0 to compile.

I quite happily use 4.0